Solved - Portal v2 settings issues


#1

We have installed Portal V2 and the installation worked fine. We can login to the portal and pay/check account balances. When we try to access the settings page we receive the error Whoops, looks like something went wrong. What logs do we need to check to see what went wrong?


#2

Travis,

You can run the following command to see what happening with the application.

docker-compose app logs

If it looks like a bug email support@sonar.software or open up an issue on Github


#3

(SonarSoftware\CustomerPortalFramework\Exceptions\ApiException(code: 0): You are not authorized to perform that action. at /var/www/html/vendor/sonarsoftware/customer_portal_framework/src/Helpers/HttpHelper.php:100)"} []
sonar-customerportal | Jun 19 16:44:01 8b4525f2ae50 CRON[400]: (www-data) CMD (cd /var/www/html && php artisan schedule:run >> /dev/null 2>&1)

edit - removed extra lines


#4

Can you confirm the portal user has the following permissions?

  • Account create, read, update, and delete permissions
  • Ticket create, read, and update permissions, ticket super user permissions
  • Financial read permissions

The ticket super user permissions is a new requirement from the v1 portal.


#5

That fixed it. I didnt notice that requirement and used the old access role. Now if I can figure out why the logo is not uploading or applying.


#6

The logo should be uploaded. Try clearing your browser cache or try incognito mode.


#7

Ahh, ok lol, that fixed it, thanks for the help