Mandrillapp - tickets


#1

I have already submitted to support, however, wanted to post here in case someone had a suggestion that might help resolve sooner.

We’ve used Sonar for a a long time with no issue, today around Noon no new tickets were being created in Sonar. We tracked everything down we could and everything looks correct, no issues with anything that we can find except for the following.

After a customer sends an email to our SUPPORT we forward it to the correct XXX@sonarticketing.rocks which is on the mandrillapp server where we get the following…

SENT:STARTTLS

RECEIVED: 220 TLS go ahead

Performing SSL/TLS handshake for session 96 (each session id is unique) Verify certificate: True, Expected remote host name:: 30612810.in1.mandrillapp.com

Certificate verification failed for session 96. Expected host: 30612810.in1.mandrillap.com, Windows error code: -2146762487, Windows error message: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider

SENT: MAIL FROM support@ourdomain.com
RECEIVED: 250 OK
SENT: RCPT TO XXX@sonarticketing.rocks
RECEIVED: 250 Accepted
SENT: Data
RECEVIED: 354 Enter message, ending with . on a line by itself
SENT: QUIT
RECEIVED: 221.mail.domain.com closing connection
Ending session 96

Result is that NO TICKET is created in Sonar which prior to Noon today worked without issue.

Any ideas?


#2

I’m speculating, but it looks like your mail server doesn’t trust the certificate for the domain. I don’t know why though.


#3

Our mail server (internal) hasn’t been changed in well over a year and we’ve done nothing in Sonar that would change anything - which makes it hard for me to understand why our email server would suddenly stop trusting the certificate.

In addition if you read the rest of the log after that issue we are still sending the email to xxx@sonarticketing.rocks and that mail server is accepting the message - although no ticket is created.

To test a theory I sent an email to xxx@sonarticketrocks from our mail server and one from a third party (i.e. hotmail/gmail) to see if a ticket was created and in both cases no ticket was created.

I’ve submitted to sonar support but figure it wold be interesting to see if you guys submit something to that email address whether or not it creates a ticket for you.


#4

https://twitter.com/mandrillapp

Looks like they’re working through it. Sorry for the disruption.


#5

AWESOME - no really, always thrilled when there is an actual issue that can be identified and worked through


#6

@Ryan_Smith1 Potential fix we are testing - create a new inbound mailbox in Sonar, and try using that one. Seems like new ones created are working, it’s just the old ones that are still affected by the outage. Might take a few attempts.