Can't add a private MAC as inventory


#1

It does not seem possible to add a private MAC address (x2:00:00:00:00:04) to inventory. We would like to use private MACs to aid in Option 82 but when we try to add anything with a private prefix (x2, x6, xa, xe) it fails with either a fatal error or "can’t be converted to a 12 character MAC) error.


#2

I’m not sure if you’re including a literal ‘x’ in the MAC address or not – that would cause it to break. You can replace the x (in the x2, x6, xa, xe first octet) with anything from 0-9 or a-f and it will be considered a locally administered MAC address.

I tried adding 02:00:00:00:00:04 to my inventory, it worked


#3

We were using a valid character in place of the “x”. What I think was going on was a more global issue with our Sonar instance. From time to time, it runs extremely slow and occasionally generates errors. When I was trying to add those private MACs, I was getting a fatal error but the instance was also super slow. Today, it worked.


#4

Have you opened a ticket with support about the slowdowns? They can investigate and help solve it for you.


#5

I have not yet. I keep assuming those slowdowns are part of the upgrade process to version 2.0 for our instance. :slight_smile:


#6

Hit 'em up, they can help!